Home > usb

Archiv für usb

Ihr kennt das – nach einem (langen) Fotoshooting kommt ihr vom Kunden oder einer Tour, schiebt Ihr die Speicherkarte(n) in das Lesegerät und importiert spannungsvoll die Bilder mittels Lightroom oder ähnlichem auf die lokale Platte… kein großer Akt.

Die Pumpe geht erst richtig an, wenn dabei der Kartenleser hektisch blinkt und kurze Zeit später das System meldet, dass die Karte nicht lesbar sei. Arschwasser. Verdammt! – Der Schlaumeier sagt jetzt: „Na hätteste mal die Kamera mit den zwei Kartenslots genommen, dann hätteste jetzt nen Backup.“ – Hätte, hätte… pfft.

Soweit so gut – Analyse. Nebenbei schon mal kurz durchkalkulieren, wie teuer ein professioneller Restore wird.

Ganz so dramatisch kann es nicht sein. Die Karte lässt sich zumindest mounten, Die Verzeichnisse und die Dateien sehe ich auch. Nur das Kopieren schlägt fehl.  Die Fehlermeldungen sagen so etwas wie „Error Code 36“, „kann Datei nicht lesen“ oder „Gerät nicht vorhanden“. Beim Kopierversuch sehe ich, dass der Mac die Karte auswirft und dann sofort wieder einhängt, folglich kann er auch nicht mehr von ihr lesen.

Kurzerhand schloss ich das Lesegerät an einen anderen Rechner an und siehe da, dort kann ich die Bilder problemlos runter kopieren. Also lässt sich das Problem auf den Mac und die Kombination mit dem Kartenleser eingrenzen.

Das Setup

Kingston-FCR-HS3Ich betreibe einen MacBook Pro Retina und ein USB 3.0-Kartenleser von Kingston. Und zwar diesen hier: Kingston Media Reader FCR-HS3. Vor kurzem habe ich auf MacOSX Mavericks aktualisiert und kann den Anfang der Probleme chronologisch darauf eingrenzen.

Nach einigen erfolglosen Suchen kam ich dann doch auf ein paar Hinweise, die die Verbindung mit Mavericks bestätigten: https://discussions.apple.com/message/23574651#23574651

Die Lösung

Die Lösung ist also das Firmware-Update des Kartenlesers. In meinem Fall war diese bei Kingston hier zu finden. Wie so oft sind dies (leider) nur Windows-Programme. Zum Glück hatte ich hiervon noch einen zur Verfügung. Nach dem Firmware-Update lief der Kartenleser dann aber wieder einwandfrei. Hui… aber die Sache mit dem neuen Body mit zwei Kartenslots könnte vielleicht trotzdem mal eine Überlegung wert sein.

Anmerkung: Verfolgt man die Threads, die zu diesem Problem existieren, scheint es kein Kingston-spezifisches Problem zu sein. Ähnliche Phänomene treten wohl auch bei SanDisk & Co. auf.